Site slowness
Incident Report for Open LMS
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 18:59 UTC
Monitoring
We are experiencing site slowness with a select few sites and are taking steps to mitigate it. We expect normal performance to return soon.
Posted Dec 13, 2021 - 20:46 UTC
This incident affected: Open LMS - North America.